魔兽世界怀旧服-1.12.x ubuntu 搭建指南


wow 1.12 作为一个经典的版本,一直以来都是很多人研究的对象,掌握了基于cmangos的编译和使用指南,其他关于mangos-zero 及 lightshope等其他模拟器的编译都是大同小异,下述为编译搭建的说明:

1. 编译环境要求

// 更新ubuntu的仓库
sudo apt-get update 
// 安装必须的编译环境
sudo apt-get install build-essential gcc g++ automake git-core \
autoconf make patch libmysql++-dev mysql-server libtool \
libssl-dev grep binutils zlibc libc6 libbz2-dev cmake subversion \
libboost-all-dev

继续阅读“魔兽世界怀旧服-1.12.x ubuntu 搭建指南”